/ mapkit-android-demo



/yandex-ads-sdk-android

Этот пакет содержит Mobile SDK Рекламной сети Яндекса и исходный код примеров использования SDK..

Документация

Документацию можно найти на [официальном веб-сайте] ДОКУМЕНТАЦИЯ

Лицензия

EULA доступно на [веб-сайте EULA] ЛИЦЕНЗИЯ

Быстрый запуск в Android Studio

1. Запуск Android Studio 1.0 или выше
2. Импортируйте один из примеров проектов:
  • /Примеры/AdMobBannerAdapterExample;
  • /Примеры/AdMobInterstitialAdapterExample;
  • /Примеры /AdMobNativeAdapterExample;
  • /Примеры/AdMobRewardedAdapterExample;
  • /Примеры/BannerExample;
  • /Examples/GdprExample;
  • /Примеры/InterstitialExample;
  • /Примеры/MobileMediationBannerExample;
  • /Примеры/MobileMediationInterstitialExample;
  • /Примеры/MobileMediationNativeExample ;
  • /Примеры/MobileMediationRewardedExample;
  • /Примеры/MoPubBannerAdapterExample;
  • /Примеры/MoPubInterstitialAdapterExample;
  • /Примеры/MoPubNativeAdapterExample;
  • /Примеры/MoPubRewardedAdapterExample;
  • /Примеры/NativeAdUnitPagerExample;
  • /Примеры/NativeExample;
  • /Примеры/NativeTemplatesExample;
  • /Примеры/NativeTemplatesRecyclerViewExample;
  • /Примеры/RewardedExample;
  • /Examples/VastExample.я>
3. Сборка и запуск.

Интеграция

Настройка gradle

Для интеграции YandexMobileAds SDK необходимо:

1. скомпилировать SDK AppMetrica:
 implementation 'com.yandex.android:mobmetricalib:3.16.2' 

2. скомпилировать YandexMobileAds SDK:
 implementation 'com.yandex.android:mobileads:3.3.0' 

репозитории {
mavenCentral ()
google ()
}
buildscript {
репозитории {
google ()
jcenter ()
}
зависимости {
classpath ‘com.android.tools .build: gradle: 4.0.1 ‘
}
}
применить плагин: «com.android.application»
android {
dependencies {
/* lite версия предоставляет только карту и некоторые основные сервисы
* полная версия предоставляет остальную часть API карт
* маршрутизация, панорамы, поиск и т.д.
* реализация ‘com.yandex.android:maps.mobile:4.0.0-lite’
*/
реализация ‘com.yandex.android:maps.mobile:4.0.0-full’
}
compileSdkVersion 29
buildToolsVersion «29.0.3»
defaultConfig {
minSdkVersion 15
targetSdkVersion 29
}
sourceSets {
main {
manifest.srcFile ‘src/main/AndroidManifest.xml’
java.srcDirs = [‘src/main/java’]
res.srcDirs = [‘src/main/res’]
}
}
}
зависимости {
реализация ‘androidx.constraintlayout: constraintlayout: 2.0.1’
}
Оцените статью
clickpad.ru
Добавить комментарий