Как установить приложения, требующие более новой версии iOS на 1-е поколение iPad?

У меня iPad 1-го поколения, и когда я загружаю приложения, он сообщает мне, что «для этого требуется iOS 6.0 или новее», но когда я иду обновлять, он сообщает мне, что он полностью обновлен? Почему это происходит и могу ли я как-нибудь это исправить?


iTunes 12.7 или более поздней версии делает это ответьте отрицательно — вы не можете этого сделать.

Теперь, когда iTunes не может управлять приложениями, вы не можете загружать их через USB.


Единственный обходной путь на данный момент — установить предыдущую версию iTunes (см. этот ответ) и следовать остальной части этого ответа.

Вот самый простой способ загрузить приложения на старую iPhone/iPad, которые не поддерживают загрузку приложений через App Store (если вы получаете сообщение об ошибке, что для загрузки требуется более новая версия программного обеспечения):

  1. На старом iPhone/iPad перейдите в Настройки -> Магазин -> установите для Приложения значение Off .

  2. Зайдите на свой компьютер (неважно, ПК это или Mac) и откройте приложение iTunes. Затем перейдите в магазин iTunes и загрузите все приложения, которые вы хотите установить на свой iPad/iPhone.

  3. Если iTunes на компьютере и ваш iPad являются одновременно выполнен вход с тем же Apple ID, и iPad подключен к Интернету, затем перейдите на iPad/iPhone в App Store -> Приобретено -> коснитесь в отдельном приложении, которое вы хотите установить.

  4. Вы получите сообщение, в котором говорится: «Для текущей версии требуется iOS 6.1 или более поздней версии, но вы можете загрузить последняя совместимая версия «просто нажмите Download .

Этот метод должен, по крайней мере, позволить вам установить большинство приложений на устаревшее устройство. . Большинство из них будут работать, но иногда даже после того, как вы установили приложение, оно все равно не будет работать правильно. Это просто невезение. Но, по моему опыту, это не так уж часто; приложения обычно работают нормально.

1


Последняя версия iOS, поддерживаемая вашей системой, — iOS 5.1.1. Вы не сможете обновить его до iOS 6.

К сожалению, это означает, что вы не сможете установить какое-либо приложение, для которого требуется iOS 6 или выше.

0


Как сказал Эдуард: последняя поддерживаемая iOS для вашего устройства — 5.1.1, и если Приложение iOS поддерживает только более новые версии iOS, тогда вы не сможете установить/обновить это приложение.

Вы можете попробовать найти аналогичное приложение с такими же функциями, которое поддерживает более старые версии iOS.

Или вы можете попытаться связаться с разработчиком программного обеспечения/компанией и попросить совместимую версию. Я сделал это для своего любимого мультимедийного приложения, и они включили мое старое устройство в качестве бета-тестера … но это необычно.

0


Как сделать исправить это кажется ответом на более ранние плакаты. Вот почему:

При написании программы можно довольно свободно выбирать, насколько она совместима с предыдущими версиями iOS. Однако чем больше он совместим, тем меньше он может использовать более новые версии, а также новые функции и новые устройства. В некоторых случаях тон может заставить его работать только с более старой или новой iOS, но не с обоими. Поэтому программисты должны двигаться вперед и исключать старые версии ОС.

Когда приложение находится в магазине приложений дольше, часто сохраняется несколько версий приложения. Таким образом, установка приложения на старые устройства работает в некоторых случаях, но не всегда. Если только ваш телефон не позволяет этого, а у других с таким же телефоном и версией iOS проблем нет, значит, что-то есть с вашим телефоном или вашей учетной записью — возможно, также с вашими покупками. Если у других есть такая же проблема, более старая версия может быть недоступна из соображений безопасности, из-за отсутствия совместимости с новыми онлайн-функциями и т.п.



Это приложение несовместимо с этим устройством iOS

Когда я обновляю свой Версия iOS от 9.3 до 9.3.1, затем перейдите в магазин приложений, чтобы установить приложение, которое мы получаем всплывающее окно, это приложение несовместимо с этим устройством. Ниже мой снимок экрана.


Установите NO в Build Active Architectures Only Release Configuration внутри Build Settings.

Изменить:

Вот объяснение, почему вам нужно установить его как NO .

Установите для этого параметра значение ДА строится только для архитектуры вашего устройства, подключенного во время сборки приложения. Это означает, что если ваше подключенное устройство является 64-разрядным устройством, эта сборка не будет работать на iPhone 5 или более старых устройствах (32-разрядных).

Установка для этого параметра значения NO создаст толстый двоичный файл, который будет работать на всех архитектурах, упомянутых в Valid Architectures в настройках сборки, что позволит ему работать на всех устройствах.

Надеюсь. это проясняет ваши сомнения. Вы можете выпустить новую сборку с правильными настройками.

JFYI, вы также можете выбрать ускоренную проверку, чтобы ваше обновление стало быстрее. (Не используйте его слишком часто).

Удачи!

Оцените статью
clickpad.ru
Добавить комментарий